Xcalibur table saw fence issues

If its got a cable, this is the place to talk about it.
Craigclose91
New Member
Posts: 2
Joined: Sat Jul 28, 2018 6:11 pm
Contact:

Xcalibur table saw fence issues

Postby Craigclose91 » Sat Jul 28, 2018 6:14 pm

Hi Guys

This is an issue I have been dealing with since I bought my table saw when I installed the fence following the manufacturers instructions I found that the fence won’t move easisily along the rail no matter what I have tried it won’t lock down correctly run smoothly or seem to sit right to move the fence I have to lift the whole thing slightly to move it which is such a bug bear I will provide as many pics as possible and any help would be so appreciated




https://pasteboard.co/HwzvbsZ.jpg
https://pasteboard.co/HwzvC3w.jpg
https://pasteboard.co/HwzvLW4.jpg
https://pasteboard.co/HwzvWgg.jpg
https://pasteboard.co/Hwzw5u7.jpg
https://pasteboard.co/HwzwfZA.jpg
https://pasteboard.co/Hwzwp1n.jpg

promhandicam
Moderator
Posts: 3397
Joined: Wed Oct 17, 2007 8:50 am
Location: Surrey / Hampshire
Contact:

Re: Xcalibur table saw fence issues

Postby promhandicam » Sat Jul 28, 2018 7:40 pm

Welcome to the forum. Have you tried contacting Axminster?

Craigclose91
New Member
Posts: 2
Joined: Sat Jul 28, 2018 6:11 pm
Contact:

Re: Xcalibur table saw fence issues

Postby Craigclose91 » Sat Jul 28, 2018 8:05 pm

I bought this saw from Woodford I asked when I got it and was told the instructions explain everything I hope it’s something simple I’m just overlooking.

cerdeira
New Member
Posts: 46
Joined: Fri Jan 07, 2011 10:37 am
Location: Near the beach in Portugal
Contact:

Re: Xcalibur table saw fence issues

Postby cerdeira » Fri Aug 03, 2018 11:11 am

I think you've probably mounted the rail far too low as seen on the last photo. The fence arrangement should slide on top of the rail and should have pads of low friction plastic underneath as well.


Return to “Power Tools and Machinery”

Who is online

Users browsing this forum: No registered users and 2 guests