Hi. Record Power CL1 help needed!

If the work spins rather than the tool, this is the place for you.
Dunkf
New Member
Posts: 1
Joined: Mon Dec 31, 2018 4:58 pm
Contact:

Hi. Record Power CL1 help needed!

Postby Dunkf » Mon Dec 31, 2018 5:22 pm

Hi All.
I need some help regarding My old (blue) Record Power CL1 lathe.
I bought it second hand quite a few years ago. It’s been great up until a couple of weeks ago. I was roughing out a fairly substantial log when I smoked the starter capacitor.
I got a replacement from eBay and used it for roughly 3 hours over a period of about a week. Today, however as I was using it the power tripped out. I reset the rcd and it tripped again.
My question is, do You think it’s the fault of the replacement capacitor, the switch or is the motor fried?
There wasn’t any smoke this time and the capacitor wasn’t hot.
Please help!!!!!

9fingers
Subscriber
Posts: 1060
Joined: Tue Oct 23, 2007 12:27 pm
Location: Romsey, Hampshire UK
Contact:

Re: Hi. Record Power CL1 help needed!

Postby 9fingers » Tue Jan 08, 2019 8:22 am

The RCD detects leakage to earth and I cannot think of any capacitor fault to cause a leak. Check for any whiskers of wire in all the connections but it could also be a dying motor which needs expert help to confirm before spending out on a new one.
Bob
Information on induction motors and inverters here
https://drive.google.com/file/d/0B_GZrX ... sp=sharing" onclick="window.open(this.href);return false;

Image


Return to “Turning”

Who is online

Users browsing this forum: No registered users and 1 guest